summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-14 22:24:01 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-14 23:43:49 +0100
commita8b0556ea1e439c89dc1ba33c8864e8b9b811f08 (patch)
treece31fecb8ce254e5b2d0f5255b0637ba8957c973 /gnu/packages/ssh.scm
parent152d4076a4b7022c7d8a8a4f78ef93d3780011ce (diff)
downloadguix-patches-a8b0556ea1e439c89dc1ba33c8864e8b9b811f08.tar
guix-patches-a8b0556ea1e439c89dc1ba33c8864e8b9b811f08.tar.gz
gnu: libssh: Update to 0.8.6.
* gnu/packages/patches/libssh-hostname-parser-bug.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/ssh.scm (libssh): Update to 0.8.6. [source](patches): Remove. [arguments]: Add #:phases. (guile-ssh)[source](modules, snippet]: New fields.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm34
1 files changed, 29 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 5c954eae35..ce77a1aa60 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
@@ -67,22 +67,31 @@
(define-public libssh
(package
(name "libssh")
- (version "0.7.7")
+ (version "0.8.6")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://git.libssh.org/projects/libssh.git")
(commit (string-append "libssh-" version))))
- (patches (search-patches "libssh-hostname-parser-bug.patch"))
(sha256
(base32
- "07adxvhmnaq2l7sq7sn4sjlikbm1zdicq8lavq5yfila6jbx9z1y"))
+ "0rq57gpmdawljx7hqya4ipzsfpcbr31yy60kl5qv66krc9wimqda"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
'(#:configure-flags '("-DWITH_GCRYPT=ON")
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'avoid-werror
+ (lambda _
+ ;; Avoid '-Werror'. Presumably this works fine with
+ ;; gcc@8 on x86_64 but leads to errors with our older
+ ;; compiler.
+ (substitute* "CompilerChecks.cmake"
+ (("-Werror=") "-W"))
+ #t)))
+
;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
#:tests? #f))
(inputs `(("zlib" ,zlib)
@@ -235,7 +244,22 @@ Additionally, various channel-specific options can be negotiated.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1g2jzcg1p25zrkx06j160qb8bgcwa3001ys4q02496xs61pvywqk"))))
+ "1g2jzcg1p25zrkx06j160qb8bgcwa3001ys4q02496xs61pvywqk"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; libssh >= 0.8.0 no longer provides libssh_threads: see
+ ;; <https://github.com/artyom-poptsov/guile-ssh/issues/9>.
+ (substitute* "libguile-ssh/Makefile.am"
+ (("-lssh_threads") ""))
+
+ ;; This test would wrongfully pick DSS keys when running on
+ ;; libssh >= 0.8.0, which fails:
+ ;; <https://github.com/artyom-poptsov/guile-ssh/issues/10>.
+ (substitute* "tests/server.scm"
+ (("= %libssh-minor-version 7")
+ ">= %libssh-minor-version 7"))
+ #t))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments