summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 14:18:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 14:26:43 +0200
commita03562b478f50c302b6398fe5793fc072ed621f2 (patch)
tree72c4a3b661acdb005e0a4a4d55e77075a0f833a2 /gnu/packages/ssh.scm
parent35284f3697969b8722eee473e6bc57453875177c (diff)
downloadguix-patches-a03562b478f50c302b6398fe5793fc072ed621f2.tar
guix-patches-a03562b478f50c302b6398fe5793fc072ed621f2.tar.gz
Revert "gnu: openssh: Remove empty /var/empty."
Oh, hello, you must be new here: $ git show ba912479e8481d69b699ce348b35d5d70f0c9367 That silly person really ought to have added a comment to the code, shouldn't they? This reverts similar changes made in commit ec7bcdc35af17021a9dfd73ef49750d0ad82b989, and adds one.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index f7e6286db0..4e217888fd 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -259,10 +259,9 @@ a server that supports the SSH-2 protocol.")
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
;; Install without host keys and system configuration files.
+ ;; This will install /var/empty to the store, which is needed
+ ;; by the system openssh-service-type.
(apply invoke "make" "install-nosysconf" make-flags)
- (with-directory-excursion out
- (rmdir "var/empty")
- (rmdir "var"))
(with-directory-excursion "contrib"
(chmod "ssh-copy-id" #o555)
(install-file "ssh-copy-id"