summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-27 22:36:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-28 04:16:35 +0100
commit511a8f8d468ad64ec8e117c827573f58552fdceb (patch)
tree4b371ffac01428cb4269c4005d9f31033aaa573c /gnu/packages/ssh.scm
parent42c4acf026a148e97be4959d63b662adece85ad0 (diff)
downloadguix-patches-511a8f8d468ad64ec8e117c827573f58552fdceb.tar
guix-patches-511a8f8d468ad64ec8e117c827573f58552fdceb.tar.gz
gnu: clustershell: Fetch sources from Git.
* gnu/packages/ssh.scm (clustershell)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 00bcdb63ab..c8a1dbbe47 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -827,12 +827,13 @@ framework.")
(version "1.8.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/cea-hpc/clustershell/releases"
- "/download/v" version
- "/ClusterShell-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cea-hpc/clustershell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1qdcgh733szwj9r1gambrgfkizvbjci0bnnkds9a8mnyb3sasnan"))))
+ (base32 "128v3gc6gj9622sp41az1jkcqnkbsdzvb2jpk12fpm1mmjcfgfvc"))))
(build-system python-build-system)
(inputs `(("openssh" ,openssh)))
(propagated-inputs `(("python-pyyaml" ,python-pyyaml)))