summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-11-25 08:24:55 -0600
committerBrett Gilio <brettg@gnu.org>2020-11-25 08:24:55 -0600
commit435739ff48ab8eefc2120af23fc296a579308987 (patch)
treedcfd11c5b11ebeea784b1eab7ed030c901af4a8e /gnu/packages/ssh.scm
parent02312f7bbe289aa87b5708c4e3b9da4ad25fe436 (diff)
downloadguix-patches-435739ff48ab8eefc2120af23fc296a579308987.tar
guix-patches-435739ff48ab8eefc2120af23fc296a579308987.tar.gz
gnu: et: Work around recursive module imports.
* gnu/packages/ssh.scm (et): Remove. * gnu/packages/terminals.scm (et): Add et.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 9f60b3c02e..e5bcac33f2 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -487,36 +487,6 @@ of user keystrokes. It's a replacement for SSH that's more robust and
responsive, especially over Wi-Fi, cellular, and long-distance links.")
(license license:gpl3+)))
-(define-public et
- (package
- (name "et")
- (version "3.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/MisterTea/EternalTCP")
- (commit (string-append "et-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1m5caxckn2ihwp9s2pbyh5amxlpwr7yc54q8s0kb10fr52w2vfnm"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs `(("glog" ,glog)
- ("gflags" ,gflags)
- ("libsodium" ,libsodium)
- ("protobuf" ,protobuf)))
- (synopsis "Remote shell that automatically reconnects")
- (description
- "Eternal Terminal (ET) is a remote shell that automatically reconnects
-without interrupting the session. Unlike SSH sessions, ET sessions will
-survive even network outages and IP changes. ET uses a custom protocol over
-TCP, not the SSH protocol.")
- (home-page "https://eternalterminal.dev/")
- (license license:asl2.0)))
-
(define-public dropbear
(package
(name "dropbear")