summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-11 20:35:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-11 22:28:22 +0100
commit2ecb5e7901ab9e826f8eb5ff21dbd84fb032c46f (patch)
treebfb162ecaba675898604eb499bd4369d500d5c98 /gnu/packages/ssh.scm
parent0222de2c65fa688a65c2435862b842b8706d7db9 (diff)
downloadguix-patches-2ecb5e7901ab9e826f8eb5ff21dbd84fb032c46f.tar
guix-patches-2ecb5e7901ab9e826f8eb5ff21dbd84fb032c46f.tar.gz
gnu: libssh: Update to 0.9.3 [fixes CVE-2019-14889].
* gnu/packages/ssh.scm (libssh): Update to 0.9.3. [arguments]: Remove #:phases.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index b82d280089..de33effc89 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -71,7 +71,7 @@
(define-public libssh
(package
(name "libssh")
- (version "0.9.2")
+ (version "0.9.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -79,23 +79,13 @@
(commit (string-append "libssh-" version))))
(sha256
(base32
- "14g4rvp91skn2hlsjyhkv58vhng65xrf34cfqffixa4al869hzgj"))
+ "175i3xybg69d5lb078334v6dd3njm743kww8f67ix9w33969rmzf"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
'(#:configure-flags '("-DWITH_GCRYPT=ON")
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'avoid-werror
- (lambda _
- ;; Avoid '-Werror'. Presumably this works fine with
- ;; gcc@8 on x86_64 but leads to errors with our older
- ;; compiler.
- (substitute* "CompilerChecks.cmake"
- (("-Werror=") "-W"))
- #t)))
-
;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
#:tests? #f))
(inputs `(("zlib" ,zlib)