summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-27 00:20:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-27 00:21:16 +0200
commit1ebb908d447fd7e641e800f970a0035ccd98deb7 (patch)
treeac154be59c5af96247be0bf7ab5888e3088211b9 /gnu/packages/ssh.scm
parentcac6c3bad531f0fec8bc08f26ece05c7f61687cf (diff)
downloadguix-patches-1ebb908d447fd7e641e800f970a0035ccd98deb7.tar
guix-patches-1ebb908d447fd7e641e800f970a0035ccd98deb7.tar.gz
Revert "gnu: openssh: Clean-up custom install phase."
This reverts commit 7754136e464e02284624ad05c196d9ec26099143.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 2fd02475d3..4bb0ad59f0 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -220,17 +220,20 @@ a server that supports the SSH-2 protocol.")
#t))
(replace 'install
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; install without host keys and system configuration files
- (apply invoke "make" "install-nosysconf" make-flags)
- (install-file "contrib/ssh-copy-id"
- (string-append out "/bin/"))
- (chmod (string-append out "/bin/ssh-copy-id") #o555)
- (install-file "contrib/ssh-copy-id.1"
- (string-append out "/share/man/man1/"))
- ;; Don't install the PRIVSEP_PATH directory.
- (delete-file-recursively (string-append out "/var"))
- #t))))))
+ ;; install without host keys and system configuration files
+ (apply invoke "make" "install-nosysconf" make-flags)
+ (install-file "contrib/ssh-copy-id"
+ (string-append (assoc-ref outputs "out")
+ "/bin/"))
+ (chmod (string-append (assoc-ref outputs "out")
+ "/bin/ssh-copy-id") #o555)
+ (install-file "contrib/ssh-copy-id.1"
+ (string-append (assoc-ref outputs "out")
+ "/share/man/man1/"))
+ ;; Don't install the PRIVSEP_PATH directory.
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out") "/var"))
+ #t)))))
(synopsis "Client and server for the secure shell (ssh) protocol")
(description
"The SSH2 protocol implemented in OpenSSH is standardised by the