summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-19 17:45:32 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-19 17:45:32 +0200
commit0fb80f349d1fa683e6016edb541f7204aee2120f (patch)
tree93c91793d1698703c574ac6594efeaa6f15273ed /gnu/packages/ssh.scm
parent7046a8fff70d2b565641b97015839d86f8e3e73d (diff)
downloadguix-patches-0fb80f349d1fa683e6016edb541f7204aee2120f.tar
guix-patches-0fb80f349d1fa683e6016edb541f7204aee2120f.tar.gz
gnu: guile-ssh: Fix test failure due to Guile 3.0.7's 'read-error'.
Reported by Marius Bakke. * gnu/packages/patches/guile-ssh-read-error.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (guile-ssh)[source]: Use it. (guile2.0-ssh)[source]: New field. (guile2.2-ssh)[source]: New field.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 820c67f28a..7723390c16 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -317,7 +317,8 @@ Additionally, various channel-specific options can be negotiated.")
(sha256
(base32
"1xpxkvgj7wgcl450djkcrmrf957mcy2f36hfs5g6kpla1gax2d1g"))
- (patches (search-patches "guile-ssh-fix-test-suite.patch"))))
+ (patches (search-patches "guile-ssh-fix-test-suite.patch"
+ "guile-ssh-read-error.patch"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments
@@ -383,6 +384,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile2.0-ssh")
+ (source (origin
+ (inherit (package-source guile-ssh))
+ (patches (search-patches "guile-ssh-fix-test-suite.patch"))))
(native-inputs
`(("guile" ,guile-2.0) ;needed when cross-compiling.
,@(alist-delete "guile" (package-native-inputs guile-ssh))))
@@ -393,6 +397,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile2.2-ssh")
+ (source (origin
+ (inherit (package-source guile-ssh))
+ (patches (search-patches "guile-ssh-fix-test-suite.patch"))))
(native-inputs
`(("guile" ,guile-2.2) ;needed when cross-compiling.
,@(alist-delete "guile" (package-native-inputs guile-ssh))))