summaryrefslogtreecommitdiff
path: root/gnu/packages/sqlite.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-08 17:48:03 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-08 17:48:57 +0200
commit5f96f303eb9438d0395ad0b66e92e435531d7700 (patch)
tree543561461535bd69b0439babcc0c589fb0908afc /gnu/packages/sqlite.scm
parent971863fb45af749639a556e905997f48e895cfa8 (diff)
downloadguix-patches-5f96f303eb9438d0395ad0b66e92e435531d7700.tar
guix-patches-5f96f303eb9438d0395ad0b66e92e435531d7700.tar.gz
gnu: Consolidate databases in (gnu packages databases).
* gnu/packages/databases.scm: New file, with the contents of the following deleted files. * gnu/packages/mysql.scm, gnu/packages/postgresql.scm, gnu/packages/recutils.scm, gnu/packages/sqlite.scm, gnu/packages/bdb.scm: Remove. * gnu-system.am (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/packages/apl.scm, gnu/packages/dc.scm, gnu/packages/games.scm, gnu/packages/gnunet.scm, gnu/packages/linux.scm, gnu/packages/mail.scm, gnu/packages/mpd.scm, gnu/packages/nvi.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/rdf.scm, gnu/packages/version-control.scm: Adjust to new module name.
Diffstat (limited to 'gnu/packages/sqlite.scm')
-rw-r--r--gnu/packages/sqlite.scm63
1 files changed, 0 insertions, 63 deletions
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
deleted file mode 100644
index e19160a864..0000000000
--- a/gnu/packages/sqlite.scm
+++ /dev/null
@@ -1,63 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages sqlite)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (srfi srfi-26)
- #:use-module (ice-9 match))
-
-(define-public sqlite
- (package
- (name "sqlite")
- (version "3.8.4.3")
- (source (origin
- (method url-fetch)
- ;; TODO: Download from sqlite.org once this bug :
- ;; http://lists.gnu.org/archive/html/bug-guile/2013-01/msg00027.html
- ;; has been fixed.
- (uri (let ((numeric-version
- (match (string-split version #\.)
- ((first-digit other-digits ...)
- (string-append first-digit
- (string-pad-right
- (string-concatenate
- (map (cut string-pad <> 2 #\0)
- other-digits))
- 6 #\0))))))
- (string-append
- "mirror://sourceforge/sqlite.mirror/SQLite%20" version
- "/sqlite-autoconf-" numeric-version ".tar.gz")))
- (sha256
- (base32
- "0rcdsk5sz34w8vy0g5yhfms4saiq81i872jxx5m5sjij7bi9bsg0"))
- (patches
- (list (search-patch "sqlite-large-page-size-fix.patch")))))
- (build-system gnu-build-system)
- (home-page "http://www.sqlite.org/")
- (synopsis "The SQLite database management system")
- (description
- "SQLite is a software library that implements a self-contained, serverless,
-zero-configuration, transactional SQL database engine. SQLite is the most
-widely deployed SQL database engine in the world. The source code for SQLite is
-in the public domain.")
- (license public-domain)))