summaryrefslogtreecommitdiff
path: root/gnu/packages/sqlite.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-06 18:46:48 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 19:49:56 +0200
commit0788e62d3e391d04e5a2fa6c399fcdfba5dcb579 (patch)
tree222a061d16dc61573986e5f3a3bfcda010d39e6b /gnu/packages/sqlite.scm
parentb4ad57ae3e5249ee7402b2ab3c41104ce9c01529 (diff)
downloadguix-patches-0788e62d3e391d04e5a2fa6c399fcdfba5dcb579.tar
guix-patches-0788e62d3e391d04e5a2fa6c399fcdfba5dcb579.tar.gz
gnu: nss: Fix test failure.
* gnu/packages/sqlite.scm (sqlite-uri): New variable. (sqlite)[source](uri): Use it. (sqlite-3.33): New public variable.
Diffstat (limited to 'gnu/packages/sqlite.scm')
-rw-r--r--gnu/packages/sqlite.scm38
1 files changed, 26 insertions, 12 deletions
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index c0ea2e670e..56e53eeae4 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -45,23 +45,26 @@
;;; This module has been separated from (gnu packages databases) to reduce the
;;; number of module references for core packages.
+(define (sqlite-uri version year)
+ (let ((numeric-version
+ (match (string-split version #\.)
+ ((first-digit other-digits ...)
+ (string-append first-digit
+ (string-pad-right
+ (string-concatenate
+ (map (cut string-pad <> 2 #\0)
+ other-digits))
+ 6 #\0))))))
+ (string-append "https://sqlite.org/" (number->string year)
+ "/sqlite-autoconf-" numeric-version ".tar.gz")))
+
(define-public sqlite
(package
(name "sqlite")
(version "3.35.5")
(source (origin
(method url-fetch)
- (uri (let ((numeric-version
- (match (string-split version #\.)
- ((first-digit other-digits ...)
- (string-append first-digit
- (string-pad-right
- (string-concatenate
- (map (cut string-pad <> 2 #\0)
- other-digits))
- 6 #\0))))))
- (string-append "https://sqlite.org/2021/sqlite-autoconf-"
- numeric-version ".tar.gz")))
+ (uri (sqlite-uri version 2021))
(patches (search-patches "sqlite-hurd.patch"))
(sha256
(base32
@@ -106,6 +109,17 @@ widely deployed SQL database engine in the world. The source code for SQLite
is in the public domain.")
(license license:public-domain)))
+(define-public sqlite-3.33
+ (package
+ (inherit sqlite)
+ (version "3.33.0")
+ (source (origin
+ (method url-fetch)
+ (uri (sqlite-uri version 2020))
+ (sha256
+ (base32
+ "05dvdfaxd552gj5p7k0i72sfam7lykaw1g2pfn52jnppqx42qshh"))))))
+
;; Column metadata support was added to the regular 'sqlite' package with
;; commit fad5b1a6d8d9c36bea5785ae4fbc1beb37e644d7.
(define-public sqlite-with-column-metadata