summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-30 10:47:35 +0200
committerDavid Craven <david@craven.ch>2016-08-05 21:48:43 +0200
commite02cd2b8fe9de08a9f33d643792ee24734ff1d6e (patch)
treefee18023a32dbfff8d12615c164f338eb13932ec /gnu/packages/spice.scm
parent38b9ce44db690dc1dafe616e1a92157dffdedef6 (diff)
downloadguix-patches-e02cd2b8fe9de08a9f33d643792ee24734ff1d6e.tar
guix-patches-e02cd2b8fe9de08a9f33d643792ee24734ff1d6e.tar.gz
gnu: spice-vdagent: Set Exec path in spice-vdagent.desktop.
* gnu/packages/spice.scm (spice-vdagent): Set Exec path in spice-vdagent.desktop.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index cfb60845bc..9e4a6695ac 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -234,6 +234,13 @@ Internet and from a wide variety of machine architectures.")
(((string-append "\\$\\(mkdir_p\\) \\$\\(DESTDIR\\)"
"\\$\\(localstatedir\\)/run/spice-vdagentd"))
"-$(mkdir_p) $(DESTDIR)$(localstatedir)/run/spice-vdagentd"))
+ #t))
+ (add-after 'unpack 'patch-spice-vdagent.desktop
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "data/spice-vdagent.desktop"
+ (("Exec=/usr/bin/spice-vdagent\n")
+ (string-append "Exec=" (assoc-ref outputs "out")
+ "/bin/spice-vdagent")))
#t)))))
(inputs
`(("alsa-lib" ,alsa-lib)