summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-11 22:42:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-11 22:42:59 -0400
commitb7cbca221f74e9e9ef43c228dca9fa9930babec5 (patch)
tree33d0c1b2ae9a09a6e50652f61cdb16c7ba5d9003 /gnu/packages/spice.scm
parentc80627731bc100baa4b6c5d265df5465cee9498e (diff)
parentfb5d04d36334784a5ac76c4a90de1e1376120885 (diff)
downloadguix-patches-b7cbca221f74e9e9ef43c228dca9fa9930babec5.tar
guix-patches-b7cbca221f74e9e9ef43c228dca9fa9930babec5.tar.gz
Merge branch 'version-1.3.0'
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 31c2ce0ebe..9833ddaf05 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -265,7 +265,7 @@ Internet and from a wide variety of machine architectures.")
(define-public spice-vdagent
(package
(name "spice-vdagent")
- (version "0.20.0")
+ (version "0.21.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -273,11 +273,14 @@ Internet and from a wide variety of machine architectures.")
"spice-vdagent-" version ".tar.bz2"))
(sha256
(base32
- "0n9k2kna2gd1zi6jv45zsp2jlv439nz5l5jjijirxqaycwi74srf"))))
+ "0n8jlc1pv6mkry161y656b1nk9hhhminjq6nymzmmyjl7k95ymzx"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
'("--localstatedir=/var")
+ ;; The test-session-info test fails for unknown reasons (see:
+ ;; https://gitlab.freedesktop.org/spice/linux/vd_agent/-/issues/24).
+ #:make-flags '("XFAIL_TESTS=tests/test-session-info")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-makefile.in
@@ -285,19 +288,27 @@ Internet and from a wide variety of machine architectures.")
(substitute* "Makefile.in"
(((string-append "\\$\\(mkdir_p\\) \\$\\(DESTDIR\\)"
"\\$\\(localstatedir\\)/run/spice-vdagentd"))
- "-$(mkdir_p) $(DESTDIR)$(localstatedir)/run/spice-vdagentd"))
- #t))
+ "-$(mkdir_p) $(DESTDIR)$(localstatedir)/run/spice-vdagentd"))))
(add-after 'unpack 'patch-spice-vdagent.desktop
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "data/spice-vdagent.desktop"
(("Exec=/usr/bin/spice-vdagent")
(string-append "Exec=" (assoc-ref outputs "out")
- "/bin/spice-vdagent")))
- #t)))))
+ "/bin/spice-vdagent")))))
+ (add-after 'unpack 'fix-test-termination
+ (lambda _
+ ;; The termination tests depend on finding the socket file name
+ ;; in the spice-vdagent command line it launched, but by default
+ ;; ps truncates its output, which causes the test to fail (see:
+ ;; https://gitlab.freedesktop.org/spice/linux/vd_agent/-/merge_requests/36).
+ (substitute* "tests/test-termination.c"
+ (("ps -ef")
+ "ps -efww")))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("dbus" ,dbus)
("glib" ,glib)
+ ("gtk+" ,gtk+)
("libdrm" ,libdrm)
("libpciaccess" ,libpciaccess)
("libx11" ,libx11)
@@ -307,7 +318,8 @@ Internet and from a wide variety of machine architectures.")
("libxrandr" ,libxrandr)
("spice-protocol" ,spice-protocol)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("procps" ,procps))) ;tests use 'ps'
(synopsis "Spice agent for Linux")
(description "Spice-vdagent enables sharing the clipboard and guest display
resolution scaling on graphical console window resize.")