summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2017-12-02 17:23:27 -0500
committerLeo Famulari <leo@famulari.name>2017-12-04 14:05:23 -0500
commitb142756d9c6a2dd6936b7175f120846190f52aaa (patch)
tree237ab5cc2d0f405e1559fbbd2d44add78b795ff0 /gnu/packages/spice.scm
parent982caeab6f33ac7956e97c86426177b5d90cf180 (diff)
downloadguix-patches-b142756d9c6a2dd6936b7175f120846190f52aaa.tar
guix-patches-b142756d9c6a2dd6936b7175f120846190f52aaa.tar.gz
gnu: spice: Update to 0.14.0.
This is a follow-up to commit 9a187b39b7991463aa6985f5b746fccf69789525. * gnu/packages/spice.scm (spice): Update to 0.14.0. [source]: Remove obsolete patches. Use HTTPS URL. [inputs]: Add orc. [home-page]: Update to use https. * gnu/packages/patches/spice-CVE-2016-9577.patch, gnu/packages/patches/spice-CVE-2016-9578-1.patch, gnu/packages/patches/spice-CVE-2016-9578-2.patch, gnu/packages/patches/spice-CVE-2017-7506.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 7d49f90be9..10f7c6bc57 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -203,20 +203,15 @@ which allows users to view a desktop computing environment.")
(define-public spice
(package
(name "spice")
- (version "0.12.8")
+ (version "0.14.0")
(source (origin
(method url-fetch)
(uri (string-append
- "http://www.spice-space.org/download/releases/"
+ "https://www.spice-space.org/download/releases/"
"spice-" version ".tar.bz2"))
(sha256
(base32
- "0za03i77j8i3g5l2np2j7vy8cqsdbkm9wbv4hjnaqq9xhz2sa0gr"))
- (patches
- (search-patches "spice-CVE-2017-7506.patch"
- "spice-CVE-2016-9577.patch"
- "spice-CVE-2016-9578-1.patch"
- "spice-CVE-2016-9578-2.patch"))))
+ "0j5q7cp5p95jk8fp48gz76rz96lifimdsx1wnpmfal0nnnar9nrs"))))
(build-system gnu-build-system)
(propagated-inputs
`(("openssl" ,openssl)
@@ -228,6 +223,7 @@ which allows users to view a desktop computing environment.")
("libjpeg-turbo" ,libjpeg-turbo)
("lz4" ,lz4)
("opus" ,opus)
+ ("orc" ,orc)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)