summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-11-18 11:16:22 +0100
committerLudovic Courtès <ludo@gnu.org>2018-11-18 12:28:34 +0100
commit8504d1922240b29815fd3e1e231e27da391338cd (patch)
treed77e7eb6811dd80203f98c9b16fd7e8155531c58 /gnu/packages/spice.scm
parentaf50b4abc0b577f7892dafce1a5e6f57150b88b0 (diff)
downloadguix-patches-8504d1922240b29815fd3e1e231e27da391338cd.tar
guix-patches-8504d1922240b29815fd3e1e231e27da391338cd.tar.gz
gnu: spice: Run tests sequentially.
* gnu/packages/spice.scm (spice)[arguments]: Add #:parallel-tests?.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index fb121a0581..94e6aa8438 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -211,6 +211,10 @@ which allows users to view a desktop computing environment.")
`(#:configure-flags
'("--enable-lz4"
"--enable-automated-tests")
+
+ ;; Several tests appear to be opening the same sockets concurrently.
+ #:parallel-tests? #f
+
#:phases (modify-phases %standard-phases
(add-before 'check 'use-empty-ssl-cert-file
(lambda _ (setenv "SSL_CERT_FILE" "/dev/null") #t)))))