summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-08 13:36:41 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:02:56 +0200
commit37d52f6e4699030cf957da306fa9b66396eb9d71 (patch)
tree96cd6025655f7bee8a2059dbbf977e2bc19b022a /gnu/packages/spice.scm
parent19c3304072ec69b0fcfe1d792c348713a5f43252 (diff)
downloadguix-patches-37d52f6e4699030cf957da306fa9b66396eb9d71.tar
guix-patches-37d52f6e4699030cf957da306fa9b66396eb9d71.tar.gz
gnu: spice: Fix usbredir for 32 bit platforms.
* gnu/packages/spice.scm (usbredir)[origin]: Fetch source from git repo. [native-inputs]: Add AUTOCONF, AUTOMAKE and LIBTOOL. [arguments]: Add autogen phase.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm34
1 files changed, 28 insertions, 6 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 9e4a6695ac..67e493a439 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -18,6 +18,7 @@
(define-module (gnu packages spice)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools) ; remove after updating usbredir to 0.7.1+
#:use-module (gnu packages compression)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -37,6 +38,7 @@
#:use-module (gnu packages xml)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix git-download) ; remove after updating usbredir to 0.7.1+
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils))
@@ -45,19 +47,39 @@
(package
(name "usbredir")
(version "0.7.1")
+ ;(source (origin
+ ; (method url-fetch)
+ ; (uri (string-append
+ ; "http://spice-space.org/download/usbredir/"
+ ; "usbredir-" version ".tar.bz2"))
+ ; (sha256
+ ; (base32
+ ; "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
+ ; FIXME: usbredir 0.7.1 release doesn't build on 32 bit systems.
+ ; issue is fixed in HEAD
+ ; remove 'autogen phase and autoconf, automake, libtool inputs
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://spice-space.org/download/usbredir/"
- "usbredir-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://cgit.freedesktop.org/spice/usbredir")
+ (commit "ac80a5971c6318d73d5fba4b5f13d3a9389558c9")))
(sha256
(base32
- "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
+ "052fywgi72j68dr5ybldncg4vk8iqfrh58la7iazyxxpph9aag1g"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libusb" ,libusb)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda* _
+ (system* "sh" "autogen.sh"))))))
(synopsis "Tools for sending USB device traffic over a network")
(description "Usbredir is a network protocol for sending USB device traffic
over a network connection. It can be used to redirect traffic from a USB device