summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-24 19:52:24 +0200
committerLeo Famulari <leo@famulari.name>2016-07-28 17:08:41 -0400
commit1d2c67c11e61f2fe10c926d1cf82dfbbe9b1e5f7 (patch)
tree047997838b6983772dc812a3c7e5bb710a366937 /gnu/packages/spice.scm
parenta1dfa0223329734d2cb4f9aa034183fb2573bb9c (diff)
downloadguix-patches-1d2c67c11e61f2fe10c926d1cf82dfbbe9b1e5f7.tar
guix-patches-1d2c67c11e61f2fe10c926d1cf82dfbbe9b1e5f7.tar.gz
gnu: Add usbredir.
* gnu/packages/spice.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
new file mode 100644
index 0000000000..c88491fbd9
--- /dev/null
+++ b/gnu/packages/spice.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 David Craven <david@craven.ch>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages spice)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages libusb)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils))
+
+(define-public usbredir
+ (package
+ (name "usbredir")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://spice-space.org/download/usbredir/"
+ "usbredir-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1wsnmk4wjpdhbn1zaxg6bmyxspcki2zgy0am9lk037rnl4krwzj0"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libusb" ,libusb)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Tools for sending USB device traffic over a network")
+ (description "Usbredir is a network protocol for sending USB device traffic
+over a network connection. It can be used to redirect traffic from a USB device
+to a different (virtual) machine than the one to which the USB device is
+attached.")
+ (home-page "http://www.spice-space.org")
+ (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))