summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-19 09:25:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-19 09:25:12 +0200
commit10e73bbc5e2a3f62dc07c5c94309c5105c435dc6 (patch)
treeb19bdfaf0e36b146b9a5fae71c77638fdb0073a0 /gnu/packages/spice.scm
parent63edbb65e4d16ebbd4c3977e93c3ebcbf0495c46 (diff)
downloadguix-patches-10e73bbc5e2a3f62dc07c5c94309c5105c435dc6.tar
guix-patches-10e73bbc5e2a3f62dc07c5c94309c5105c435dc6.tar.gz
gnu: spice-gtk: Build with vala support.
* gnu/packges/spice.scm (spice-gtk)[native-inputs]: Add vala. [arguments]: Add '--enable-vala' to configure-flags.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 4787f107f0..edc6135fbd 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -157,12 +157,14 @@ which allows users to view a desktop computing environment.")
(native-inputs
`(("glib:bin" ,glib "bin")
("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
(arguments
`(#:configure-flags
'("--enable-gstaudio"
"--enable-gstvideo"
"--enable-pulse"
+ "--enable-vala"
"--enable-introspection")
#:phases
(modify-phases %standard-phases