summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-26 09:38:29 +0200
committerLudovic Courtès <ludo@gnu.org>2018-03-26 09:38:29 +0200
commit07a049ceb1a394cde2b91c0c73638827834f6f1f (patch)
tree5757c6809603fda2196ff643a5f03dedd09685c0 /gnu/packages/spice.scm
parent51602aac8e9449e39441693553f7afb87094ee14 (diff)
downloadguix-patches-07a049ceb1a394cde2b91c0c73638827834f6f1f.tar
guix-patches-07a049ceb1a394cde2b91c0c73638827834f6f1f.tar.gz
gnu: usbredir: Build without '-Werror'.
Fixes build failure introduced in 58ee8a94a90eb40496b9704d541b5dfbbf1685ba, where compilation would fail with: usbredirhost.c: In function ?usbredirhost_open_full?: usbredirhost.c:749:5: error: ?libusb_set_debug? is deprecated: Use libusb_set_option instead [-Werror=deprecated-declarations] libusb_set_debug(host->ctx, host->verbose); ^ In file included from usbredirhost.h:24:0, from usbredirhost.c:31: /gnu/store/j8hzc465xy33cjfcq3wv39szxia4xrzv-libusb-1.0.22/include/libusb-1.0/libusb.h:1300:18: note: declared here void LIBUSB_CALL libusb_set_debug(libusb_context *ctx, int level); ^ cc1: all warnings being treated as errors * gnu/packages/spice.scm (usbredir)[arguments]: In 'autogen' phase, remove '-Werror' from configure.ac.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index fb3b11ba2d..521be54c49 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -86,6 +86,10 @@
(modify-phases %standard-phases
(add-after 'unpack 'autogen
(lambda _
+ ;; Build without '-Werror', in particular to avoid errors due
+ ;; to the use of the deprecated 'libusb_set_debug' function.
+ (substitute* "configure.ac"
+ (("-Werror") ""))
(zero? (system* "autoreconf" "-vfi")))))))
(synopsis "Tools for sending USB device traffic over a network")
(description "Usbredir is a network protocol for sending USB device traffic