summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
commitf056553c6b8ffa36f4ce9fb1c3602a8f4b1de242 (patch)
tree80c815216a3717cf00b615c9cb8840c113eaf79f /gnu/packages/sphinx.scm
parent2c9d34166983565120f831284df57a07e2edd2f9 (diff)
parent528b52390d216d8a8cd13dfcd1e6e40a6448e6c2 (diff)
downloadguix-patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar
guix-patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm34
1 files changed, 29 insertions, 5 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 64c1fc3318..b74137362c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -30,6 +30,7 @@
(define-module (gnu packages sphinx)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
@@ -375,13 +376,14 @@ integrate Sphinx documents in web templates and to handle searches.")
(name "python-sphinx-gallery")
(version "0.1.13")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/sphinx-gallery/sphinx-gallery"
- "/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sphinx-gallery/sphinx-gallery")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "03fs99mcb1r7qp0xixqv07vcz98sk21yq19ffdysi0infdcpzfkd"))))
+ "14nbqh9krx2l2y2ylbln6l6w8iak3wac1lngvaf278y1cx7685kg"))))
(build-system python-build-system)
(arguments
;; FIXME: Tests attempt to download <https://docs.python.org/3/objects.inv>,
@@ -541,3 +543,25 @@ and several other projects.")
(define-public python2-sphinx-rtd-theme
(package-with-python2 python-sphinx-rtd-theme))
+
+(define-public python-breathe
+ (package
+ (name "python-breathe")
+ (version "4.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "breathe" version))
+ (sha256
+ (base32
+ "1aw749n2ry27434qd7gr99dvsrs3x3chyi9aywmhjj1g4m2j6xf6"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-six" ,python-six)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/michaeljones/breathe")
+ (synopsis "ReStructuredText and Sphinx bridge to Doxygen")
+ (description "This package is an extension to reStructuredText and Sphinx
+to be able to read and render the Doxygen xml output.")
+ (license license:bsd-3)))