summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-13 22:10:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-13 22:10:44 +0200
commitd090a1c15a799e34ed8c4793b462d518d9932191 (patch)
tree5cc7809c31dfbf21d2082c4c8d132aac1fa63bd4 /gnu/packages/sphinx.scm
parent520cca28ee782065ecfff35efee460ab7d00a699 (diff)
downloadguix-patches-d090a1c15a799e34ed8c4793b462d518d9932191.tar
guix-patches-d090a1c15a799e34ed8c4793b462d518d9932191.tar.gz
gnu: python-sphinx-gallery: Don't use unstable tarball.
* gnu/packages/sphinx.scm (python-sphinx-gallery)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 8c658c286d..1f3553bcdb 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -30,6 +30,7 @@
(define-module (gnu packages sphinx)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
@@ -375,13 +376,14 @@ integrate Sphinx documents in web templates and to handle searches.")
(name "python-sphinx-gallery")
(version "0.1.13")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/sphinx-gallery/sphinx-gallery"
- "/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sphinx-gallery/sphinx-gallery")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "03fs99mcb1r7qp0xixqv07vcz98sk21yq19ffdysi0infdcpzfkd"))))
+ "14nbqh9krx2l2y2ylbln6l6w8iak3wac1lngvaf278y1cx7685kg"))))
(build-system python-build-system)
(arguments
;; FIXME: Tests attempt to download <https://docs.python.org/3/objects.inv>,