summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-03-03 21:57:21 -0600
committerEric Bavier <bavier@member.fsf.org>2021-03-14 13:24:21 -0500
commitb15720182e393bc26e9d61ea4d7534b7eea19390 (patch)
treece7a8d35ce6d8d5bb7db235bf2ec84ee44b70b89 /gnu/packages/sphinx.scm
parent2babf7d831f77a379a6fdc70a70a2b4d57f68f8a (diff)
downloadguix-patches-b15720182e393bc26e9d61ea4d7534b7eea19390.tar
guix-patches-b15720182e393bc26e9d61ea4d7534b7eea19390.tar.gz
gnu: Add python-sphobjinv.
* gnu/packages/sphinx.scm (python-sphobjinv): New variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index e046885a6b..29872ed942 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -697,3 +698,27 @@ their results) in both HTML and LaTeX output. Un-evaluated notebooks
- i.e. notebooks without stored output cells - will be automatically
executed during the Sphinx build process.")
(license license:expat)))
+
+(define-public python-sphobjinv
+ (package
+ (name "python-sphobjinv")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphobjinv" version))
+ (sha256
+ (base32
+ "126lgm54c94ay3fci512ap4l607gak90pbz0fk98syxvj5izrrzx"))
+ (patches (search-patches "python-sphobjinv-system-ca.patch"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ;("python-certifi" ,python-certifi)
+ ("python-fuzzywuzzy" ,python-fuzzywuzzy)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-levenshtein" ,python-levenshtein)))
+ (home-page "https://github.com/bskinn/sphobjinv")
+ (synopsis "Sphinx cross-reference tool")
+ (description "Sphinx objects.inv inspection/manipulation tool.")
+ (license license:expat)))