summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2019-12-16 04:42:22 +0000
committerBrett Gilio <brettg@posteo.net>2019-12-15 22:53:50 -0600
commit90ee17cdac77e48603b93ab30b71c4ba7ce2db42 (patch)
tree6eeca54ab5d28c0f009e9e72c2e0d2c87aa887ad /gnu/packages/sphinx.scm
parent00386d3430f12710997f17091a55c07323ff138c (diff)
downloadguix-patches-90ee17cdac77e48603b93ab30b71c4ba7ce2db42.tar
guix-patches-90ee17cdac77e48603b93ab30b71c4ba7ce2db42.tar.gz
gnu: Add python-sphinx-intl
* gnu/packages/sphinx.scm (python-sphinx-intl): New variable. Signed-off-by: Brett Gilio <brettg@posteo.net>
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b74137362c..a3958d2c9b 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -565,3 +566,26 @@ and several other projects.")
(description "This package is an extension to reStructuredText and Sphinx
to be able to read and render the Doxygen xml output.")
(license license:bsd-3)))
+
+(define-public python-sphinx-intl
+ (package
+ (name "python-sphinx-intl")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-intl" version))
+ (sha256
+ (base32
+ "0zbf1bh23b3kza8bnjykmv2k21xmmr4gamhi3lnicnr6ypnrphr5"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-sphinx" ,python-sphinx)
+ ("python-click" ,python-click)))
+ (home-page "https://github.com/sphinx-doc/sphinx-intl")
+ (synopsis
+ "Sphinx utility that makes it easy to translate and to apply translation")
+ (description
+ "A utility tool that provides several features that make it easy to
+translate and to apply translation to Sphinx generated document.")
+ (license license:bsd-2)))