summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2019-12-23 17:22:42 -0600
committerBrett Gilio <brettg@gnu.org>2019-12-23 17:22:42 -0600
commit8d45404e3fde06beb2d3740ef234542e58b4b162 (patch)
treecf94f43f60ec10e6e7b2b8f00560a7ebdc35b6d6 /gnu/packages/sphinx.scm
parent50bb74d0f23013040aa4cf55a19ee296d462188d (diff)
downloadguix-patches-8d45404e3fde06beb2d3740ef234542e58b4b162.tar
guix-patches-8d45404e3fde06beb2d3740ef234542e58b4b162.tar.gz
gnu: python-sphinx-copybutton: Update to 0.2.6.
* gnu/packages/sphinx.scm (python-sphinx-copybutton): Update to 0.2.6. [arguments]: Disable tests. [propagated-inputs]: Add python-flit, python-setuptools, python-sphinx, python-wheel.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 8343d0a5f2..e1e2d42673 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -169,15 +169,22 @@ Apple help books.")
(define-public python-sphinx-copybutton
(package
(name "python-sphinx-copybutton")
- (version "0.2.5")
+ (version "0.2.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sphinx-copybutton" version))
(sha256
(base32
- "1bk006nv5s9ym6v67cxd4d2wvd8wm6czqi21mqcs33risygksncl"))))
+ "0ny9jpygj93z8jyjpi4v6jjz90pmns74s389wq16igzzq2mpgfjm"))))
(build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; XXX: Check requires network access.
+ (propagated-inputs
+ `(("python-flit" ,python-flit)
+ ("python-setuptools" ,python-setuptools)
+ ("python-sphinx" ,python-sphinx)
+ ("python-wheel" ,python-wheel)))
(home-page "https://github.com/choldgraf/sphinx-copybutton")
(synopsis "Sphinx extension to add \"copy\" buttons to code blocks")
(description