summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-15 04:37:46 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-10 15:32:45 +0100
commit6a887e4909d4973c942d8cd62cd11a5c1070c254 (patch)
treede4b374092926af8298b392cd96d46c623f75cdf /gnu/packages/sphinx.scm
parentdc5ace95d3cab2a81ecf16338342a069f8ce7705 (diff)
downloadguix-patches-6a887e4909d4973c942d8cd62cd11a5c1070c254.tar
guix-patches-6a887e4909d4973c942d8cd62cd11a5c1070c254.tar.gz
gnu: Add python-sphinxext-opengraph.
* gnu/packages/sphinx.scm (python-sphinxext-opengraph): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 86b867871a..9aafcb9213 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -693,6 +693,38 @@ to be able to read and render the Doxygen xml output.")
translate and to apply translation to Sphinx generated document.")
(license license:bsd-2)))
+(define-public python-sphinxext-opengraph
+ (package
+ (name "python-sphinxext-opengraph")
+ (version "0.4.2")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/wpilibsuite/sphinxext-opengraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dka44wri7agcr1jd641hq6j7qlbycligp80ngf32l5asqz1mgzp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-pytest" ,python-pytest)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/wpilibsuite/sphinxext-opengraph")
+ (synopsis "Sphinx Extension to enable OpenGraph support")
+ (description
+ "This package provides a Sphinx Extension to generate OG metadata.")
+ (license license:bsd-3)))
+
(define-public python-sphinx-autobuild
(package
(name "python-sphinx-autobuild")