summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2019-11-07 20:03:49 +0800
committer宋文武 <iyzsong@member.fsf.org>2019-11-11 20:30:53 +0800
commit68f0de01fcf9d80ce910dccdf7fa31203b3bb2b4 (patch)
treec84f2e5718c98a720b839fb385176a7953b69f08 /gnu/packages/sphinx.scm
parent0d01a5a9d47781f63c7bea3f6065fb0bed9f07f8 (diff)
downloadguix-patches-68f0de01fcf9d80ce910dccdf7fa31203b3bb2b4.tar
guix-patches-68f0de01fcf9d80ce910dccdf7fa31203b3bb2b4.tar.gz
gnu: Add python-breathe.
* gnu/packages/sphinx.scm (python-breathe): New package.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index da7492c42e..8c658c286d 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -541,3 +541,25 @@ and several other projects.")
(define-public python2-sphinx-rtd-theme
(package-with-python2 python-sphinx-rtd-theme))
+
+(define-public python-breathe
+ (package
+ (name "python-breathe")
+ (version "4.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "breathe" version))
+ (sha256
+ (base32
+ "1aw749n2ry27434qd7gr99dvsrs3x3chyi9aywmhjj1g4m2j6xf6"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-six" ,python-six)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/michaeljones/breathe")
+ (synopsis "ReStructuredText and Sphinx bridge to Doxygen")
+ (description "This package is an extension to reStructuredText and Sphinx
+to be able to read and render the Doxygen xml output.")
+ (license license:bsd-3)))