summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-22 18:25:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-22 21:17:18 +0200
commit46143878074b1935b653d9f44f408ac04fc71f70 (patch)
treec612b1242ddece370df4da64ee32a5b21889d3ac /gnu/packages/sphinx.scm
parent8efa775653f78dad8b254e719677e663be8f3240 (diff)
downloadguix-patches-46143878074b1935b653d9f44f408ac04fc71f70.tar
guix-patches-46143878074b1935b653d9f44f408ac04fc71f70.tar.gz
gnu: Add python-sphinx-panels.
* gnu/packages/sphinx.scm (python-sphinx-panels): New variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 2bea80e5c6..69592b14b3 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -300,6 +300,38 @@ Blog, News or Announcements section to a Sphinx website.")
(home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
(license license:bsd-2)))
+(define-public python-sphinx-panels
+ (package
+ (name "python-sphinx-panels")
+ (version "0.6.0")
+ (source
+ (origin
+ ;; Tests not included in the pypi release.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/executablebooks/sphinx-panels")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ivqz6yv96a2jp59kylg1gbkrmzq6zwilppz3ij0zrkjn25zb97k"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-docutils python-sphinx))
+ (native-inputs
+ (list python-pytest
+ python-pytest-regressions))
+ (home-page "https://github.com/executablebooks/sphinx-panels")
+ (synopsis "Sphinx extension for creating panels in a grid layout")
+ (description
+ "This package provides a sphinx extension for creating panels in a grid layout.")
+ (license license:expat)))
+
(define-public python-sphinxcontrib-programoutput
(package
(name "python-sphinxcontrib-programoutput")