summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-12-10 21:49:25 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-10 21:49:25 +0100
commit32750e8c3ed38df4cafb39cffa878c6851abc899 (patch)
treedcf40b321c3b492bd1d00244c78f72160e66a554 /gnu/packages/sphinx.scm
parent6104071e483095f9fea9700e0317e84f64102ae2 (diff)
parente1e32303129c5aedc7236d5cc854d6b72ad35daf (diff)
downloadguix-patches-32750e8c3ed38df4cafb39cffa878c6851abc899.tar
guix-patches-32750e8c3ed38df4cafb39cffa878c6851abc899.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 6a5a276caf..471988b178 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -526,6 +526,37 @@ introspection of @code{zope.interface} instances in code.")
(define-public python2-sphinx-repoze-autointerface
(package-with-python2 python-sphinx-repoze-autointerface))
+(define-public python-sphinx-prompt
+ (package
+ (name "python-sphinx-prompt")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch) ; no source release in PyPI
+ (uri (git-reference
+ (url "https://github.com/sbrunner/sphinx-prompt")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x9wmgf04rzivbzp7jv1b7fkhkpi02lpk5w1qf4i7bcgih00ym8a"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/sbrunner/sphinx-prompt")
+ (synopsis "Sphinx directive to add unselectable prompt")
+ (description
+ "This package provides a Sphinx directive to add unselectable prompt.")
+ (license license:bsd-3)))
+
(define-public python-sphinx-alabaster-theme
(package
(name "python-sphinx-alabaster-theme")
@@ -686,6 +717,38 @@ to be able to read and render the Doxygen xml output.")
translate and to apply translation to Sphinx generated document.")
(license license:bsd-2)))
+(define-public python-sphinxext-opengraph
+ (package
+ (name "python-sphinxext-opengraph")
+ (version "0.4.2")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/wpilibsuite/sphinxext-opengraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dka44wri7agcr1jd641hq6j7qlbycligp80ngf32l5asqz1mgzp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-pytest" ,python-pytest)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/wpilibsuite/sphinxext-opengraph")
+ (synopsis "Sphinx Extension to enable OpenGraph support")
+ (description
+ "This package provides a Sphinx Extension to generate OG metadata.")
+ (license license:bsd-3)))
+
(define-public python-sphinx-autobuild
(package
(name "python-sphinx-autobuild")