summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-21 23:44:54 +0100
committerMarius Bakke <marius@gnu.org>2020-12-21 23:44:54 +0100
commit119fd58922b00d43d4f8b055f3f622478a13f46d (patch)
tree4869f9f09079d5a33f7dfd51ca8e52200fbeb09f /gnu/packages/sphinx.scm
parent85ba5e9335207beef9a650e96d5d64787beb9256 (diff)
parentbbe4ed65ed5fe7dc8ed9d226042852387cee3b1e (diff)
downloadguix-patches-119fd58922b00d43d4f8b055f3f622478a13f46d.tar
guix-patches-119fd58922b00d43d4f8b055f3f622478a13f46d.tar.gz
Merge branch 'ungrafting' into staging
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 6a3440cca4..182d2e21e5 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -597,3 +598,32 @@ translate and to apply translation to Sphinx generated document.")
documentation when a change is detected. It also includes a livereload
enabled web server.")
(license license:expat)))
+
+(define-public python-nbsphinx
+ (package
+ (name "python-nbsphinx")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nbsphinx" version))
+ (sha256
+ (base32
+ "0j56bxdj08vn3q1804qwb1ywhga1mdg1awgm7i64wfpfwi8df2zm"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-jinja2" ,python-jinja2)
+ ("python-nbconvert" ,python-nbconvert)
+ ("python-nbformat" ,python-nbformat)
+ ("python-sphinx" ,python-sphinx)
+ ("python-traitlets" ,python-traitlets)))
+ (home-page "https://nbsphinx.readthedocs.io/")
+ (synopsis "Jupyter Notebook Tools for Sphinx")
+ (description "@code{python-nbsphinx} is a Sphinx extension that
+provides a source parser for @code{*.ipynb} files. Custom Sphinx
+directives are used to show Jupyter Notebook code cells (and of course
+their results) in both HTML and LaTeX output. Un-evaluated notebooks
+- i.e. notebooks without stored output cells - will be automatically
+executed during the Sphinx build process.")
+ (license license:expat)))