summaryrefslogtreecommitdiff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-24 12:53:18 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-05-26 08:50:09 -0400
commit9698f4b74bc37439971e4b040421cc591eb1b9b7 (patch)
tree5aa8f42281c5f69a5667fc181a2619ed83c8ad44 /gnu/packages/speech.scm
parent6b0686fa9350cad5aa5cd85abd6721f4c12cc0ba (diff)
downloadguix-patches-9698f4b74bc37439971e4b040421cc591eb1b9b7.tar
guix-patches-9698f4b74bc37439971e4b040421cc591eb1b9b7.tar.gz
gnu: Add mitlm.
* gnu/packages/speech.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
new file mode 100644
index 0000000000..95c7591480
--- /dev/null
+++ b/gnu/packages/speech.scm
@@ -0,0 +1,51 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages speech)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages gcc))
+
+(define-public mitlm
+ (package
+ (name "mitlm")
+ (version "0.4.1")
+ ;; No official release tarballs, so for now we use the one from Debian
+ ;; that is maintained by one of the project developers.
+ ;;
+ ;; See: https://github.com/mitlm/mitlm/issues/54
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://debian/pool/main/m/mitlm/mitlm_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32
+ "12m09xxx8jbir9cnzzaysvni5sfijpfj96z1x1520qqvmpc8lmn7"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (synopsis "The MIT Language Modeling toolkit")
+ (description "The MIT Language Modeling (MITLM) toolkit is a set of
+tools designed for the efficient estimation of statistical n-gram language
+models involving iterative parameter estimation. It achieves much of its
+efficiency through the use of a compact vector representation of n-grams.")
+ (home-page "https://github.com/mitlm/mitlm")
+ (license license:expat)))