summaryrefslogtreecommitdiff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-19 09:49:46 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-19 09:49:46 +0000
commit84f39130a5d9254d006df2bc2460711fa6116dee (patch)
treebffc5ed3ecf22069c681ce95b3128b720abde5e0 /gnu/packages/speech.scm
parent174c29a8e09456618eacabe15c8d4a1b0e5a6b10 (diff)
downloadguix-patches-84f39130a5d9254d006df2bc2460711fa6116dee.tar
guix-patches-84f39130a5d9254d006df2bc2460711fa6116dee.tar.gz
gnu: festival: Fix build with -fcommon.
* gnu/packages/speech.scm (festival)[arguments]: Add phase "set-fcommon" to add "-fcommon" to compiler flags.
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index cbc46b32b4..8914d6d20e 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
@@ -366,6 +366,11 @@ be used by the sighted.")
"config/make_system.mak")
(("/bin/sh") (which "sh"))))
#t))
+ (add-after 'unpack-and-patch-speech-tools 'set-fcommon
+ (lambda _
+ (substitute* "../speech_tools/config/rules/defaults.mak"
+ (("\\(CFLAGS\\)") "(CFLAGS) -fcommon")
+ (("\\(CXXFLAGS\\)") "(CXXFLAGS) -fcommon"))))
(add-after 'unpack 'patch-/bin/sh
(lambda _
(substitute* '("config/test_make_rules"