summaryrefslogtreecommitdiff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
authorqblade <qblade@protonmail.com>2021-02-24 11:35:35 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-27 12:44:33 +0100
commit652861139fd92a5f8e55350c3d6286d9d8776ac3 (patch)
tree4a66c74eaed54c69f47115aa6db513af176c01a4 /gnu/packages/speech.scm
parent6c304e02330617839ca95c106dcae12e02f6e39d (diff)
downloadguix-patches-652861139fd92a5f8e55350c3d6286d9d8776ac3.tar
guix-patches-652861139fd92a5f8e55350c3d6286d9d8776ac3.tar.gz
gnu: add ekho.
* gnu/packages/speech.scm (ekho): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 66d8fca31b..4c9d3cf688 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -555,6 +556,40 @@ low level architecture and has a Scheme (SIOD) based command interpreter for
control.")
(license (license:non-copyleft "file://COPYING"))))
+(define-public ekho
+ (package
+ (name "ekho")
+ (version "8.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/e-guidedog/Ekho/"
+ version "/ekho-" version ".tar.xz"))
+ (sha256
+ (base32 "1v476kpw09ljj8mavasj4hya2w11jwlx7q22rh1lsn9jkkam5i2a"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("espeak-ng" ,espeak-ng)
+ ("libsndfile" ,libsndfile)
+ ("pulseaudio" ,pulseaudio)))
+ (build-system gnu-build-system)
+ (native-search-paths
+ (list (search-path-specification
+ (variable "EKHO_DATA_PATH")
+ (files '("share/ekho-data")))))
+ (home-page "https://eguidedog.net/ekho.php")
+ (synopsis "Chinese text-to-speech software")
+ (description
+ "Ehko is a Text-To-Speech (TTS) software. It supports Cantonese,
+Mandarin, Toisanese, Zhaoan Hakka, Tibetan, Ngangien and Korean (in trial).
+It can also speak English through eSpeak or Festival.")
+ (license (list license:gpl2+
+ ;; libmusicxml
+ license:mpl2.0))))
+
(define-public sphinxbase
(package
(name "sphinxbase")