summaryrefslogtreecommitdiff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-13 14:48:29 +0200
committerMarius Bakke <marius@gnu.org>2021-06-13 15:34:01 +0200
commit3090e6104a2ee975bc4ddfc6422b60cc8b6bc3c4 (patch)
tree2aa88020592c1055f58558002f433c41fbda8807 /gnu/packages/speech.scm
parent2b315ebfb97b8819f73d9c986cc73d729f30b5a5 (diff)
downloadguix-patches-3090e6104a2ee975bc4ddfc6422b60cc8b6bc3c4.tar
guix-patches-3090e6104a2ee975bc4ddfc6422b60cc8b6bc3c4.tar.gz
gnu: speech-dispatcher: Update to 0.10.2.
* gnu/packages/speech.scm (speech-dispatcher): Update to 0.10.2. [arguments]: Disable one new TTS engine. [native-inputs]: Remove INTLTOOL. Add GETTEXT-MINIMAL and TEXINFO.
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 093f6f957b..cbc46b32b4 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -40,6 +40,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages emacs)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
@@ -239,7 +240,7 @@ efficiency through the use of a compact vector representation of n-grams.")
(define-public speech-dispatcher
(package
(name "speech-dispatcher")
- (version "0.9.1")
+ (version "0.10.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/brailcom/speechd/releases"
@@ -247,17 +248,18 @@ efficiency through the use of a compact vector representation of n-grams.")
version ".tar.gz"))
(sha256
(base32
- "16bg52hnkrsrs7kgbzanb34b9zb6fqxwj0a9bmsxmj1skkil1h1p"))))
+ "1p72x9vsqvmhz1ym2bcpiqscn063rxdsylv65735cpp107r1jqxh"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-static"
;; Disable support for proprietary TTS engines.
- "--with-ibmtts=no"
+ "--with-voxin=no" "--with-ibmtts=no"
"--with-kali=no" "--with-baratinoo=no")))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
(inputs
`(("dotconf" ,dotconf)
("espeak" ,espeak-ng)