summaryrefslogtreecommitdiff
path: root/gnu/packages/smalltalk.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-31 14:07:50 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-06-04 13:40:02 +0200
commitf50a88c1fa2e07a668ee87402a5462267d1baf12 (patch)
treeb67324190ccfad37cedda37ab3e99698632ce7d8 /gnu/packages/smalltalk.scm
parent961a8f130275dc18cc8e602e0b2ab08b780eb46f (diff)
downloadguix-patches-f50a88c1fa2e07a668ee87402a5462267d1baf12.tar
guix-patches-f50a88c1fa2e07a668ee87402a5462267d1baf12.tar.gz
gnu: smalltalk: Find glibc even when cross-compiling.
glibc is named "cross-libc" instead of "libc" when cross-compiling. Smalltalk still fails to cross-compile though. * gnu/packages/smalltalk.scm (smalltalk)[arguments]{phases}<#:fix-libc>: Also search for "cross-libc" instead of only "libc" in 'inputs'. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/smalltalk.scm')
-rw-r--r--gnu/packages/smalltalk.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
index af4b7642ff..26f7ab2c76 100644
--- a/gnu/packages/smalltalk.scm
+++ b/gnu/packages/smalltalk.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -103,7 +104,11 @@
#t))
(add-before 'configure 'fix-libc
(lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc")))
+ (let ((libc (or (assoc-ref inputs "libc")
+ ;; When cross-compiling, the input
+ ;; is named "cross-libc" instead of
+ ;; simply "libc".
+ (assoc-ref inputs "cross-libc"))))
(substitute* "libc.la.in"
(("@LIBC_SO_NAME@") "libc.so")
(("@LIBC_SO_DIR@") (string-append libc "/lib"))))