summaryrefslogtreecommitdiff
path: root/gnu/packages/slang.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 17:08:11 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 17:08:11 -0500
commitefb0a04ee05f43e86b3c1fcda867a123d8ed021a (patch)
tree3701cf10239745148f70f72a537c6c408f39460c /gnu/packages/slang.scm
parent0df12a32bba43a0b559b11fba55f080a17fae9b9 (diff)
downloadguix-patches-efb0a04ee05f43e86b3c1fcda867a123d8ed021a.tar
guix-patches-efb0a04ee05f43e86b3c1fcda867a123d8ed021a.tar.gz
gnu: slang: Fix build on 32 bit systems.
* gnu/packages/slang.scm (slang)[phases]{reduce-array-test-size}: New phase.
Diffstat (limited to 'gnu/packages/slang.scm')
-rw-r--r--gnu/packages/slang.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/slang.scm b/gnu/packages/slang.scm
index 404a4535ca..e3c9134d60 100644
--- a/gnu/packages/slang.scm
+++ b/gnu/packages/slang.scm
@@ -57,14 +57,21 @@
#:parallel-build? #f ; there's at least one race
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'reduce-array-test-size
+ ;; Reduce the size of the array, otherwise the array.sl/array.slc
+ ;; tests fails with "Unable to create a multi-dimensional array of
+ ;; the desired size" on 32 bit systems.
+ (lambda _
+ (substitute* "src/test/array.sl"
+ (("10000,10000,10000,10000,10000,10000")
+ "100,100,100,100,100,100"))))
(add-before 'configure 'substitute-before-config
(lambda* (#:key inputs #:allow-other-keys)
(let ((ncurses (assoc-ref inputs "ncurses")))
(substitute* "configure"
(("MISC_TERMINFO_DIRS=\"\"")
(string-append "MISC_TERMINFO_DIRS="
- "\"" ncurses "/share/terminfo" "\"")))
- #t))))))
+ "\"" ncurses "/share/terminfo" "\"")))))))))
(inputs
`(("readline" ,readline)
("zlib" ,zlib)