summaryrefslogtreecommitdiff
path: root/gnu/packages/skarnet.scm
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2016-07-30 16:05:29 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-01 01:11:57 +0200
commit915db95f67aecd4390fedfa31a0e01cf3805744d (patch)
tree5e53c0c61ad46676ac5d4bbf7dbe8d51c4fb8100 /gnu/packages/skarnet.scm
parent35977a8897db26a309df9afa487a52c09ecece29 (diff)
downloadguix-patches-915db95f67aecd4390fedfa31a0e01cf3805744d.tar
guix-patches-915db95f67aecd4390fedfa31a0e01cf3805744d.tar.gz
gnu: Add s6-portable-utils.
* gnu/packages/skarnet.scm (s6-portable-utils): New variable. Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/skarnet.scm')
-rw-r--r--gnu/packages/skarnet.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 1eda4461e1..7486c239d7 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -246,3 +246,36 @@ one-time initialization scripts, in the proper order according to a dependency
tree. It ensures that long-running daemons are supervised by the s6
infrastructure, and that one-time scripts are also run in a controlled
environment.")))
+
+(define-public s6-portable-utils
+ (package
+ (name "s6-portable-utils")
+ (version "2.0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://skarnet.org/software/s6-portable-utils/s6-portable-utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0jwxj0ma4zd1h6i3i98nsp0miidr54phap7dqwf6c8vafq9psfr3"))))
+ (build-system gnu-build-system)
+ (inputs `(("skalibs" ,skalibs)))
+ (arguments
+ '(#:configure-flags (list
+ (string-append "--with-lib="
+ (assoc-ref %build-inputs "skalibs")
+ "/lib/skalibs")
+ (string-append "--with-sysdeps="
+ (assoc-ref %build-inputs "skalibs")
+ "/lib/skalibs/sysdeps"))
+ #:tests? #f))
+ (home-page "http://skarnet.org/software/s6-portable-utils")
+ (license isc)
+ (synopsis "Tiny command-line Unix utilities")
+ (description
+ "s6-portable-utils is a set of tiny general Unix utilities, often
+performing well-known tasks such as @command{cut} and @command{grep}, but
+optimized for simplicity and small size. They were designed for embedded
+systems and other constrained environments, but they work everywhere.")))