summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/simulation.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
downloadguix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar
guix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm31
1 files changed, 12 insertions, 19 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index ebf249e155..f5fe3fcf1d 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -823,33 +823,29 @@ tools and a collection of Python modules for programmatic use.")
(define-public python-pygmsh
(package
(name "python-pygmsh")
- (version "7.1.9")
+ (version "7.1.11")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "pygmsh" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nschloe/pygmsh")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1q7nr0cq581wlif537y6awj7vz9jywxg14c8znmsx5ip8x24754j"))
+ "0g4yllmxks7yb50vild5xi1cma0yl16vsq6rfvdwmqaj4hwxcabk"))
(modules '((guix build utils)))
(snippet
'(begin
(let ((file (open-file "setup.py" "a")))
(display "from setuptools import setup\nsetup()" file)
(close-port file))
- ;; setuptools is supplied by the build system. An extra
- ;; reference in the original configuration file triggers
- ;; an attempt to download the package again. This fails.
- ;; The extra reference is unnecessary and is removed.
+ ;; A reference to setuptools in the configuration file
+ ;; triggers an attempt to download the package from pypi.
+ ;; The reference is not needed since the package is
+ ;; provided by the build system.
(substitute* "setup.cfg"
(("^[[:blank:]]+setuptools>=42\n") ""))
- ;; FIXME: gmsh version 4.7.0 introduces new field option
- ;; names. See gmsh commit 6eab8028. pygmsh needs to use
- ;; one of the old option names for compatibility with gmsh
- ;; version 4.6.0.
- (with-directory-excursion "pygmsh/common"
- (substitute* "size_field.py"
- (("NumPointsPerCurve") "NNodesByEdge")))
#t))))
(build-system python-build-system)
(native-inputs
@@ -867,10 +863,7 @@ tools and a collection of Python modules for programmatic use.")
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- ;; The readme test is skipped. It requires the exdown
- ;; module which is not available.
- (invoke "python" "-m" "pytest" "-v" "test"
- "--ignore" "test/test_readme.py"))
+ (invoke "python" "-m" "pytest" "-v" "tests"))
#t)))))
(home-page "https://github.com/nschloe/pygmsh")
(synopsis "Python frontend for Gmsh")