summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-08-23 12:33:20 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-08-23 12:39:43 +0100
commitd6c2fc37292f5bd75a7fd26ae4bccf649175c00e (patch)
tree3be7bb3b6b886b385cb0e5868f06eafcf7aefbb0 /gnu/packages/simulation.scm
parentefde98a4438c2dd733bdb64fd6be9d1d5ac3b897 (diff)
downloadguix-patches-d6c2fc37292f5bd75a7fd26ae4bccf649175c00e.tar
guix-patches-d6c2fc37292f5bd75a7fd26ae4bccf649175c00e.tar.gz
gnu: python-pygmsh: Update to 7.1.11.
*gnu/packages/simulation.scm (python-pygmsh): Update to 7.1.11. [source](snippet): Re-phrase comment.
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index a2c65b73c8..23580322bb 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -843,27 +843,27 @@ tools and a collection of Python modules for programmatic use.")
(define-public python-pygmsh
(package
(name "python-pygmsh")
- (version "7.1.10")
+ (version "7.1.11")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/nschloe/pygmsh")
- (commit (string-append "v" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "03a949nl99ny9h0ni8lqgaljgkgicd305ls6zy1vkwgfa4mzsgqh"))
+ "0g4yllmxks7yb50vild5xi1cma0yl16vsq6rfvdwmqaj4hwxcabk"))
(modules '((guix build utils)))
(snippet
'(begin
(let ((file (open-file "setup.py" "a")))
(display "from setuptools import setup\nsetup()" file)
(close-port file))
- ;; setuptools is supplied by the build system. An extra
- ;; reference in the original configuration file triggers
- ;; an attempt to download the package again. This fails.
- ;; The extra reference is unnecessary and is removed.
+ ;; A reference to setuptools in the configuration file
+ ;; triggers an attempt to download the package from pypi.
+ ;; The reference is not needed since the package is
+ ;; provided by the build system.
(substitute* "setup.cfg"
(("^[[:blank:]]+setuptools>=42\n") ""))
#t))))