summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-22 20:25:51 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-06 15:23:06 +0200
commitb7d2644cd04f0f14e22d4c7232a508e6e7e2299e (patch)
tree36f20f2583195c563c5acdf384ffd32d44a946e5 /gnu/packages/simulation.scm
parent9d5160bc8af8bea7eae77ba785574936cd3945be (diff)
downloadguix-patches-b7d2644cd04f0f14e22d4c7232a508e6e7e2299e.tar
guix-patches-b7d2644cd04f0f14e22d4c7232a508e6e7e2299e.tar.gz
gnu: fenics: Fix sanity check.
* gnu/packages/simulation.scm (fenics)[arguments]: Relax pybind11 requirement to appease the sanity check. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 230ae62826..b15743f747 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -607,6 +607,10 @@ user interface to the FEniCS core components and external libraries.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "python/setup.py"
+ (("pybind11==") "pybind11>="))))
(add-after 'patch-source-shebangs 'set-paths
(lambda _
;; Define paths to store locations.