summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorOntje Lünsdorf <ontje.luensdorf@dlr.de>2022-06-27 11:51:10 +0200
committerLudovic Courtès <ludo@gnu.org>2022-08-03 12:03:51 +0200
commitb13966a907e763b41715b9cb3dda7d7b88af2b9f (patch)
tree0dd76d3fa149758afb6ae2be4b059523cb86d22b /gnu/packages/simulation.scm
parentae0c11f9209b1e09997c224b3df645f7ed4d6804 (diff)
downloadguix-patches-b13966a907e763b41715b9cb3dda7d7b88af2b9f.tar
guix-patches-b13966a907e763b41715b9cb3dda7d7b88af2b9f.tar.gz
gnu: fenics: Do not mpirun tests.
* gnu/packages/simulation.scm (fenics)[phases]: Do not use mpirun for tests and skip failing XDMF test. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 9e92fbcc5b..b1bbb7f996 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -665,15 +665,13 @@ user interface to the FEniCS core components and external libraries.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(with-directory-excursion "test"
- ;; Note: The test test_snes_set_from_options() in the file
- ;; unit/nls/test_PETScSNES_solver.py fails and is ignored.
- ;; Limit the number of jobs to 3 as 500 MiB of memory is used
- ;; per process.
- (invoke "mpirun" "-np" (number->string
- (min 3 (parallel-job-count)))
- "python" "-B" "-m"
- "pytest" "unit" "--ignore"
- "unit/nls/test_PETScSNES_solver.py")))))
+ (invoke
+ "pytest" "unit"
+ ;; The test test_snes_set_from_options() in the file
+ ;; unit/nls/test_PETScSNES_solver.py fails and is ignored.
+ "--ignore" "unit/nls/test_PETScSNES_solver.py"
+ ;; Fails with a segfault.
+ "--ignore" "unit/io/test_XDMF.py")))))
(add-after 'install 'install-demo-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((demos (string-append