summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-08-13 09:22:32 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-08-13 09:28:21 +0100
commit2caf9eafb6f4703d8f1af42123093f4a7f7a32ce (patch)
tree6725626adafb44870e6a23306d787f4ea6919a5f /gnu/packages/simulation.scm
parent74b82ecd0eca64fe11728e286cabbd4da07b8391 (diff)
downloadguix-patches-2caf9eafb6f4703d8f1af42123093f4a7f7a32ce.tar
guix-patches-2caf9eafb6f4703d8f1af42123093f4a7f7a32ce.tar.gz
gnu: python-pygmesh: Update to 7.1.10.
* gnu/packages/simulation.scm (python-pygmah): Update to 7.1.10. [arguments]<#:phases>: Tests have moved to the 'tests' directory. The test_readme.py file has been removed.
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 7a313621d1..a2c65b73c8 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -843,7 +843,7 @@ tools and a collection of Python modules for programmatic use.")
(define-public python-pygmsh
(package
(name "python-pygmsh")
- (version "7.1.9")
+ (version "7.1.10")
(source
(origin
(method git-fetch)
@@ -853,7 +853,7 @@ tools and a collection of Python modules for programmatic use.")
(file-name (git-file-name name version))
(sha256
(base32
- "1lq16v31sifd9n1bb8yxnp3vhafrxz1rvydk9hh1add96fbjgj29"))
+ "03a949nl99ny9h0ni8lqgaljgkgicd305ls6zy1vkwgfa4mzsgqh"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -883,10 +883,7 @@ tools and a collection of Python modules for programmatic use.")
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- ;; The readme test is skipped. It requires the exdown
- ;; module which is not available.
- (invoke "python" "-m" "pytest" "-v" "test"
- "--ignore" "test/test_readme.py"))
+ (invoke "python" "-m" "pytest" "-v" "tests"))
#t)))))
(home-page "https://github.com/nschloe/pygmsh")
(synopsis "Python frontend for Gmsh")