summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-23 23:05:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:52 -0500
commit1ebb629c14623f08eadb4f036ebefe3c7ba19de7 (patch)
tree18fa489ff082195ec17678aa3435f2170dcf7593 /gnu/packages/simulation.scm
parentc868f3a8f5e5d789582fce9cb4f44f105d1d708d (diff)
downloadguix-patches-1ebb629c14623f08eadb4f036ebefe3c7ba19de7.tar
guix-patches-1ebb629c14623f08eadb4f036ebefe3c7ba19de7.tar.gz
gnu: fenics: Do not alter PYTHONPATH.
* gnu/packages/simulation.scm (fenics)[phases]: Delete trailing #t. [phases]{pre-check}: Do not alter PYTHONPATH.
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm20
1 files changed, 6 insertions, 14 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 4c56342b2a..fe93e68076 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -401,7 +401,8 @@ FIAT is part of the FEniCS Project.")
;; prior to running the tests.
(invoke "py.test" "unit/" "--ignore=unit/ufc/")
(with-directory-excursion "uflacs"
- (invoke "py.test" "unit/"))))))))
+ (invoke "py.test" "unit/")))
+ #t)))))
(home-page "https://bitbucket.org/fenics-project/ffc/")
(synopsis "Compiler for finite element variational forms")
(description "The FEniCS Form Compiler (FFC) is a compiler for
@@ -616,8 +617,7 @@ user interface to the FEniCS core components and external libraries.")
;; Define paths to store locations.
(setenv "PYBIND11_DIR" (assoc-ref %build-inputs "pybind11"))
;; Move to python sub-directory.
- (chdir "python")
- #t))
+ (chdir "python")))
(add-after 'build 'mpi-setup
,%openmpi-setup)
(add-before 'check 'pre-check
@@ -659,14 +659,8 @@ user interface to the FEniCS core components and external libraries.")
"d for d in demos if d[0].stem not in "
"excludeList]\n")))
(setenv "HOME" (getcwd))
- (setenv "PYTHONPATH"
- (string-append
- (getcwd) "/build/lib.linux-x86_64-"
- ,(version-major+minor (package-version python)) ":"
- (getenv "PYTHONPATH")))
;; Restrict OpenBLAS to MPI-only in preference to MPI+OpenMP.
- (setenv "OPENBLAS_NUM_THREADS" "1")
- #t))
+ (setenv "OPENBLAS_NUM_THREADS" "1")))
(replace 'check
(lambda _
(with-directory-excursion "test"
@@ -678,8 +672,7 @@ user interface to the FEniCS core components and external libraries.")
(min 3 (parallel-job-count)))
"python" "-B" "-m"
"pytest" "unit" "--ignore"
- "unit/nls/test_PETScSNES_solver.py"))
- #t))
+ "unit/nls/test_PETScSNES_solver.py"))))
(add-after 'install 'install-demo-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((demos (string-append
@@ -693,8 +686,7 @@ user interface to the FEniCS core components and external libraries.")
(unless (equal? "." dir)
(mkdir-p tgt-dir)
(install-file file tgt-dir))))
- (find-files "." ".*\\.(py|gz|xdmf)$"))))
- #t)))))
+ (find-files "." ".*\\.(py|gz|xdmf)$")))))))))
(home-page "https://fenicsproject.org/")
(synopsis "High-level environment for solving differential equations")
(description