summaryrefslogtreecommitdiff
path: root/gnu/packages/simh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 19:48:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 20:26:53 +0100
commit4c23e261d1ac26d0fd8cca21f139d0249f17c11e (patch)
tree74f910936b862c2f7f1194d22366ff4be0b96497 /gnu/packages/simh.scm
parentb4d5a789b6ca3819d75834bf73685b0fdb121a0a (diff)
downloadguix-patches-4c23e261d1ac26d0fd8cca21f139d0249f17c11e.tar
guix-patches-4c23e261d1ac26d0fd8cca21f139d0249f17c11e.tar.gz
gnu: simh: Don't use unstable tarball.
* gnu/packages/simh.scm (simh)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/simh.scm')
-rw-r--r--gnu/packages/simh.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/simh.scm b/gnu/packages/simh.scm
index 8547b705e0..bbca246bc1 100644
--- a/gnu/packages/simh.scm
+++ b/gnu/packages/simh.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +21,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages admin))
@@ -27,14 +29,15 @@
(package
(name "simh")
(version "3.9-0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/" name "/" name
- "/archive/v" version ".tar.gz"))
- (sha256
- (base32
- "1ymfy8j15d1aa4ai5xv9w7mk6lk4zx3zhfv0mfn66pdhrc8jlh0g"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/simh/simh.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1jiq6shj6a9xvzacvmyhxxd6xdyica8q4006qqjh5mh96rxrp15c"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs
`(("libpcap" ,libpcap)))