summaryrefslogtreecommitdiff
path: root/gnu/packages/shishi.scm
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2013-04-05 23:08:44 +0000
committerNikita Karetnikov <nikita@karetnikov.org>2013-04-08 12:04:37 +0000
commitcbca6eb55298a7205ca3533957ff2e3857140f40 (patch)
tree14443504e0762f765c8a47b630a2392a7418ba7a /gnu/packages/shishi.scm
parent4f7d8d7ee4c3a2f92cd12d7e1e2a03725f406012 (diff)
downloadguix-patches-cbca6eb55298a7205ca3533957ff2e3857140f40.tar
guix-patches-cbca6eb55298a7205ca3533957ff2e3857140f40.tar.gz
gnu: shishi: Update to 1.0.2.
* gnu/packages/shishi.scm (shishi): Update to 1.0.2. * gnu/packages/patches/shishi-gets-undeclared.patch: Remove it. * Makefile.am (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/shishi.scm')
-rw-r--r--gnu/packages/shishi.scm46
1 files changed, 16 insertions, 30 deletions
diff --git a/gnu/packages/shishi.scm b/gnu/packages/shishi.scm
index 1590221496..767037a580 100644
--- a/gnu/packages/shishi.scm
+++ b/gnu/packages/shishi.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -18,12 +18,11 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages shishi)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:select (gpl3+))
#:use-module (gnu packages)
#:use-module (gnu packages gnutls)
#:use-module (gnu packages gnupg)
- #:use-module ((gnu packages compression)
- #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages compression)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -31,41 +30,28 @@
(define-public shishi
(package
(name "shishi")
- (version "1.0.1")
+ (version "1.0.2")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://gnu/shishi/shishi-"
- version
- ".tar.gz"))
+ (uri (string-append "mirror://gnu/shishi/shishi-"
+ version ".tar.gz"))
(sha256
(base32
- "13c6w9rpaqb3am65nrn86byvmll5r78pld2vb0i68491vww4fzlx"))))
+ "032qf72cpjdfffq1yq54gz3ahgqf2ijca4vl31sfabmjzq9q370d"))))
(build-system gnu-build-system)
- (arguments
- `(#:make-flags
- '("CPPFLAGS=-DMAX_ERROR_DESCRIPTION_SIZE=ASN1_MAX_ERROR_DESCRIPTION_SIZE")
- #:patches (list (assoc-ref %build-inputs
- "patch/gets"))))
(inputs
`(("gnutls" ,gnutls)
- ("zlib" ,guix:zlib)
+ ("zlib" ,zlib)
("libgcrypt" ,libgcrypt)
- ("libtasn1" ,libtasn1)
- ("patch/gets" ,(search-patch "shishi-gets-undeclared.patch"))))
+ ("libtasn1" ,libtasn1)))
(home-page "http://www.gnu.org/software/shishi/")
(synopsis
- "GNU Shishi, free implementation of the Kerberos 5 network security system")
+ "GNU Shishi, an implementation of the Kerberos 5 network security system")
(description
- " GNU Shishi is an implementation of the Kerberos 5 network
- authentication system, as specified in RFC 4120. Shishi can be
- used to authenticate users in distributed systems.
-
- Shishi contains a library (`libshishi') that can be used by
- application developers to add support for Kerberos 5. Shishi
- contains a command line utility (1shishi') that is used by
- users to acquire and manage tickets (and more). The server
- side, a Key Distribution Center, is implemented by `shishid'.
-")
- (license gpl3+))) ; some files are under GPLv2+
+ "Shishi contains a library ('libshishi') that can be used by application
+developers to add support for Kerberos 5. Shishi contains a command line
+utility ('shishi') that is used by users to acquire and manage tickets (and
+more). The server side, a Key Distribution Center (KDC), is implemented by
+'shishid', and support X.509 authenticated TLS via GnuTLS.")
+ (license gpl3+)))