summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorCollin J. Doering <collin@rekahsoft.ca>2019-09-11 23:08:37 -0400
committerLudovic Courtès <ludo@gnu.org>2019-09-13 10:50:11 +0200
commitf69f37d54a677c1816b225ead7503a4e3cfee24d (patch)
treea020d68ef86e3006d5e6dd62505b468355c532e0 /gnu/packages/shellutils.scm
parenta00a3132c7c5585e75862b479be1c63fde36b29d (diff)
downloadguix-patches-f69f37d54a677c1816b225ead7503a4e3cfee24d.tar
guix-patches-f69f37d54a677c1816b225ead7503a4e3cfee24d.tar.gz
gnu: Add sh-z shell tool
* gnu/packages/shellutils.scm (sh-z): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index f7542ea759..f901eaaa8f 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
+;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,43 @@
#:use-module (guix build-system go)
#:use-module (guix build-system python))
+(define-public sh-z
+ (package
+ (name "sh-z")
+ (version "1.11")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rupa/z.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13zbgkj6y0qhvn5jpkrqbd4jjxjr789k228iwma5hjfh1nx7ghyb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests provided
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man/man1"))
+ (bin (string-append out "/bin")))
+ (install-file "z.sh" bin)
+ (chmod (string-append bin "/z.sh") #o755)
+ (install-file "z.1" man)
+ #t))))))
+ (synopsis "Jump about directories")
+ (description
+ "Tracks your most used directories, based on ``frecency''. After a short
+learning phase, z will take you to the most ``frecent'' directory that matches
+all of the regexes given on the command line in order.")
+ (home-page "https://github.com/rupa/z")
+ (license license:expat)))
+
(define-public envstore
(package
(name "envstore")