summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-06 07:02:40 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:53 +0100
commitea18b4c5298c8cdcea22472f8cf8ce8fb3180a78 (patch)
treecb2249472a0ce93f97a1d12fd3dfbcc4ffbfc8ad /gnu/packages/shellutils.scm
parentcba0395c99005f94e4ccd6c058362af7443dab12 (diff)
downloadguix-patches-ea18b4c5298c8cdcea22472f8cf8ce8fb3180a78.tar
guix-patches-ea18b4c5298c8cdcea22472f8cf8ce8fb3180a78.tar.gz
gnu: Add ascii.
* gnu/packages/shellutils.scm (ascii): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 70443f5019..61cc124815 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -55,6 +55,44 @@
#:use-module (gnu packages tmux)
#:use-module (gnu packages vim))
+(define-public ascii
+ (package
+ (name "ascii")
+ (version "3.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.catb.org/~esr/ascii/"
+ "ascii-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0b87vy06s8s3a8q70pqavsbk4m4ff034sdml2xxa6qfsykaj513j"))))
+ (build-system gnu-build-system)
+ (arguments `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'create-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man1 (string-append out "/share/man/man1")))
+ (mkdir-p bin)
+ (mkdir-p man1)))))
+ #:tests? #f))
+ (home-page "http://www.catb.org/~esr/ascii/")
+ (synopsis "ASCII name and synonym chart")
+ (description
+ "The @code{ascii} utility provides easy conversion between various byte
+representations and the American Standard Code for Information Interchange
+(ASCII) character table. It knows about a wide variety of hex, binary, octal,
+Teletype mnemonic, ISO/ECMA code point, slang names, XML entity names, and
+other representations. Given any one on the command line, it will try to
+display all others. Called with no arguments it displays a handy small ASCII
+chart.")
+ (license license:bsd-2)))
+
(define-public boxes
(package
(name "boxes")