summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorDion Mendel <guix@dm9.info>2021-04-25 18:57:21 +0800
committerLeo Famulari <leo@famulari.name>2021-04-25 13:41:59 -0400
commit862a88612f903ffe5cca1213ba40010876d19c62 (patch)
treecbd285e441598a7f210d279e0cd6546e458be363 /gnu/packages/shellutils.scm
parent1897a6efa77e341a091e40140d02b525eabb3fdf (diff)
downloadguix-patches-862a88612f903ffe5cca1213ba40010876d19c62.tar
guix-patches-862a88612f903ffe5cca1213ba40010876d19c62.tar.gz
gnu: direnv: Install the documentation.
* gnu/packages/shellutils.scm (direnv)[arguments]: Add a new 'install-manpages' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index c7a941dfa6..b60cb0866d 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 aecepoglu <aecepoglu@fastmail.fm>
+;;; Copyright © 2020 Dion Mendel <guix@dm9.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -254,6 +255,15 @@ are already there.")
;; so delete the extra source code here.
(delete-file-recursively "src/github.com/direnv/direnv/vendor")
#t))
+ (add-after 'install 'install-manpages
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man/man1")))
+ (mkdir-p man)
+ (with-directory-excursion "src/github.com/direnv/direnv"
+ (install-file "man/direnv.1" man)
+ (install-file "man/direnv-stdlib.1" man)
+ (install-file "man/direnv.toml.1" man)))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?