summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorMatthew Jordan <matthewjordandevops@yandex.com>2016-05-19 14:10:40 -0400
committerLudovic Courtès <ludo@gnu.org>2016-05-21 23:30:37 +0200
commit548994142f52c168454ee725227aef6a975cb880 (patch)
treefd3fa0bff18c70ac52b30b4697b6a23912fe8f55 /gnu/packages/shellutils.scm
parentb9b447be64fcde6ebb5811ee82a6f029b873ab18 (diff)
downloadguix-patches-548994142f52c168454ee725227aef6a975cb880.tar
guix-patches-548994142f52c168454ee725227aef6a975cb880.tar.gz
gnu: Add envstore.
* gnu/package/shellutils.scm: New file. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
new file mode 100644
index 0000000000..8108b0465d
--- /dev/null
+++ b/gnu/packages/shellutils.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages shellutils)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu))
+
+(define-public envstore
+ (package
+ (name "envstore")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://finalrewind.org/projects/"
+ name "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "1x97lxad80m5blhdfanl5v2qzjwcgbij2i23701bn8mpyxsrqszi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://finalrewind.org/projects/envstore/")
+ (synopsis "Save and restore environment variables")
+ (description "Envstore is a program for sharing environment variables
+between various shells or commands.")
+ (license
+ (non-copyleft "http://www.wtfpl.net/txt/copying/"))))