summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-11-24 09:31:26 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-11-24 09:31:26 +0300
commit39bf4e0bad499aa6f9388164e73197a501915ff6 (patch)
treeec0834d2afbd79155579ed1dd2fa74c2408f1a26 /gnu/packages/shellutils.scm
parent446316cad52430d345f34b164242dab9f0ed5024 (diff)
downloadguix-patches-39bf4e0bad499aa6f9388164e73197a501915ff6.tar
guix-patches-39bf4e0bad499aa6f9388164e73197a501915ff6.tar.gz
gnu: Add shell-functools.
* gnu/packages/shellutils.scm (shell-functools): New variable.
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 83bbb55f6b..a5d2601de9 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -316,3 +316,26 @@ commands that are obsolete or contain a piece of sensitive information) or
bookmark your favourite commands.")
(home-page "http://me.mindforger.com/projects/hh.html")
(license license:asl2.0)))
+
+(define-public shell-functools
+ (package
+ (name "shell-functools")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharkdp/shell-functools.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d6zzg7cxfrzwzh1wmpj7q85kz33sak6ac59ncsm6dlbin12h0hi"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/sharkdp/shell-functools/")
+ (synopsis "Functional programming tools for the shell")
+ (description "This package provides higher order functions like map,
+filter, foldl, sort_by and take_while as simple command-line tools. Following
+the UNIX philosophy, these commands are designed to be composed via pipes. A
+large collection of functions such as basename, replace, contains or is_dir
+are provided as arguments to these commands.")
+ (license license:expat)))