summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-13 22:02:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-13 22:02:25 +0200
commit2bbda4f077513aa70cb10150fc1c0a808b2657ea (patch)
tree768589fa74a87072f86c8b51ebdbf433daccbb62 /gnu/packages/shellutils.scm
parentd177ac2df66031cf8150ed82136628350cebf5c7 (diff)
downloadguix-patches-2bbda4f077513aa70cb10150fc1c0a808b2657ea.tar
guix-patches-2bbda4f077513aa70cb10150fc1c0a808b2657ea.tar.gz
gnu: hstr: Don't use unstable tarball.
* gnu/packages/shellutils.scm (hstr)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 6630332692..83bbb55f6b 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -279,13 +279,14 @@ below the current cursor position, scrolling the screen if necessary.")
(name "hstr")
(version "2.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/dvorka/" name "/archive/"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dvorka/hstr.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0yk2008bl48hv0v3c90ngq4y45h3nxif2ik6s3l7kag1zs5yv4wd"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "1y9vsfbg07gbic0daqy569d9pb9i1d07fym3q7a0a99hbng85s20"))))
(build-system gnu-build-system)
(arguments
`(#:phases