summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-12 15:17:45 -0400
committerLeo Famulari <leo@famulari.name>2018-09-12 15:21:42 -0400
commitff9008d8debae7b32a8d27da7ab2fef7c9322196 (patch)
tree4aabad9208e0a2c9735a07b171d66bbbf62b1b91 /gnu/packages/shells.scm
parent4fa7f29f2ad7867f348e39e465c29f466203126c (diff)
downloadguix-patches-ff9008d8debae7b32a8d27da7ab2fef7c9322196.tar
guix-patches-ff9008d8debae7b32a8d27da7ab2fef7c9322196.tar.gz
gnu: Zsh: Remove workaround required for Zsh 5.6.
This is a followup to commit 5a5d3e356311620df253d7c213c1bda79cd20128. * gnu/packages/shells.scm (zsh)[arguments]: Remove substitutions in 'patch-test' phase.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 73e51da1cd..c0f1c479ef 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -336,19 +336,6 @@ history mechanism, job control and a C-like syntax.")
(("command -pv") "command -v")
(("command -p") "command ")
(("'command' -p") "'command' "))
- ;; This file is ISO-8859-1 encoded.
- (with-fluids ((%default-port-encoding #f))
- (substitute* "Test/A05execution.ztst"
- ;; Help it find `sh`
- (("PATH=/bin:\\$\\{ZTST_testdir\\}/command.tmp/ tstcmd-slashless")
- (string-append "PATH=/bin:"
- (assoc-ref %build-inputs "bash") "/bin:"
- "${ZTST_testdir}/command.tmp/ tstcmd-slashless"))
- ;; Help it find `echo`
- (("PATH=/bin:\\$\\{ZTST_testdir\\}/command.tmp tstcmd-arg")
- (string-append "PATH=/bin:"
- (assoc-ref %build-inputs "coreutils") "/bin:"
- "PATH=/bin:${ZTST_testdir}/command.tmp tstcmd-arg"))))
#t)))))
(native-inputs `(("autoconf" ,autoconf)))
(inputs `(("ncurses" ,ncurses)