summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-05 20:36:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-06 00:40:32 +0200
commitefe8dc71feddfaf1917f64fb6778fca79475f251 (patch)
treec0de92fcd7e20d73330dd6a4e5d75104b3189703 /gnu/packages/shells.scm
parent70f619d8921e70ab0e4a61d336fa9c4332014b88 (diff)
downloadguix-patches-efe8dc71feddfaf1917f64fb6778fca79475f251.tar
guix-patches-efe8dc71feddfaf1917f64fb6778fca79475f251.tar.gz
gnu: loksh: Update to 6.9.
* gnu/packages/shells.scm (loksh): Update to 6.9. [source]: Check out recursively. [build-systems]: Switch to Meson. [inputs]: Remove libbsd. [arguments]: Remove the old build system's #:make-flags and #:phases customisation.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index e9e9a845fe..cc260d4820 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -65,6 +65,7 @@
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -750,30 +751,26 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(define-public loksh
(package
(name "loksh")
- (version "6.6")
+ (version "6.9")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/dimkr/loksh")
- (commit version)))
+ (commit version)
+ ;; Include the ‘lolibc’ submodule, a static compatibility library
+ ;; created for and currently used only by loksh.
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "1a8s64n97ikvvi7ckirxnnjvcmhr3dd4rnqm2ivapyzb0wp42jk7"))))
- (build-system gnu-build-system)
+ (base32 "0x33plxqhh5202hgqidgccz5hpg8d2q71ylgnm437g60mfi9z0px"))))
+ (build-system meson-build-system)
(inputs
- `(("libbsd" ,libbsd)
- ("ncurses" ,ncurses)))
+ `(("ncurses" ,ncurses)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- `(#:tests? #f ; no tests included
- #:make-flags (list "CC=gcc" "HAVE_LIBBSD=1"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ `(#:tests? #f)) ; no tests included
(home-page "https://github.com/dimkr/loksh")
(synopsis "Korn Shell from OpenBSD")
(description